Micromax mmx 300g modem.

Discussion in 'Bsnl 3g' started by rajeevsg, Dec 30, 2009.

  1. rajeevsg

    rajeevsg New Member

    Sir,

    I have purchased bsnl 3g data card micromax mmx 300g and i want to install it on linux but when i have attached it on linux it will not showing please help how to install and configure bsnl 3g connection.

    Rajeev.
  2. essbebe

    essbebe LEARNER

    @rajeevsg

    3g data card micromax mmx 300g linux OS

    Please type in Google search box above
    Micromax mmx 300g modem.

    I find some threads for Ubuntu.
    Was the hardware detected when you plugged it in ?

    I am not familiar with LINUX OS.
  3. rajeevsg

    rajeevsg New Member

    I am using Fedora 11 and it will recognised as a hard disk not a modem.

    Rajeev.
  4. mukeshccu

    mukeshccu New Member

    First of all as you might have noticed this device has two modes one is the storage device mode where it acts like a usb CDROM and the other is the modem mode. the Storage mode is the default mode.

    To make this device work the first obvious thing to do would be to switch its usb mode.

    First just for the heck of it look at the output of lsusb

    one of the lines would go like 0x1c9e:0xf000

    right this is the vendor:productid for storage mode of this modem

    the vendorid:productid for modem mode is 0x1c9e:0x9603

    get this file
    (www) (dot) (draisberghof (dot) de/usb_modeswitch/usb_modeswitch-1.0.2.tar.bz2)

    First of all you need to extract it enter the extracted folder

    copy the file usb_modeswitch to /usr/bin

    $ sudo cp usb_modeswitch /usr/bin/

    copy usb_modeswitch.conf to /etc folder

    $ sudo cp usb_modeswitc.conf /etc/

    open up usb_modeswitch.conf and add the following lines at the end ##########
    # Settings for Micromax MMX 300G USB Modem
    ##########
    DefaultVendor = 0x1c9e
    DefaultProduct = 0xf000

    TargetVendor = 0x1c9e
    TargetProduct = 0x9603

    MessageEndpoint=0x01

    MessageContent="55534243123456788000000080000606f50402527000000000000000000000"



    Thats the correct config for Micromax MMX 300G modem.

    run the command

    $ sudo /usr/bin/usb_modeswitch

    run lsusb again

    voila: the modem mode is on. notice the new productid showing in the lsusb output

    Wrap up by mounting the modem:
    $ modprobe usbserial vendor=0x1c9e product=0x9603

Share This Page