Latest firmware for UT300R2U DSL Modem

Discussion in 'BSNL broadband' started by xendig, Mar 7, 2009.

  1. xendig

    xendig New Member

    Hi,

    Is there an updated firmware version for this modem? Current running version is 3.08.BSNL_02.01.02_tr64.

    Through the telnet interface I gathered that it's running Linux 2.6.8.1. And I am looking for an update that could possibly fix the issue I am running into.


    Linux version 2.6.8.1 (root.newbuildpc) (gcc version 3.4.2) #1 Mon Mar 12 13:20:57 IST 2007


    I have a Linksys PAP2 VOIP adapter behind the modem and every time the IP address changes on the DSL modem, the Linux netfilter stateful connection entries are not flushed and I lose voice service forever until I reboot the DSL modem.

    Here are the details of the current firmware the modem came up with.

    Board ID: 96338L-2M-8M
    Software Version: 3.08.BSNL_02.01.02_tr64.
    Bootloader (CFE) Version: 1.0.37-8.7
    Firmware Version: UT300R2U.0011.01
    Hardware Version: UT300R2U 2.2
    Model Name: UT300R2U


    I would appreciate if you anybody can share an updated firmware version. I called up the BSNL CS and they are pretty clueless.

    Thanks.
  2. essbebe

    essbebe LEARNER

    utstar web sites . No Fw updates allowed.
    You will asked to contact your ISP.

    you can try at AT YOUR OWN RISK
    Beetel220BX1 FW updates. ( check Airtel forum)
    Same board.

    After opening the modem
    type in address bar
    192.168.1.1/look.html
    Post results.

    mine:
    Board ID: 96338L-2M-8M
    Software Version: 3.12L.01.A2pB023k.d20k_rc2
    Bootloader (CFE) Version: 1.0.37-0.7
  3. George101

    George101 New Member

    is it safe to update to beetel firmware. what r its advantages?
  4. essbebe

    essbebe LEARNER

    UT300R2U new BSNL modem FW version/board ID

    @George101.
    After opening the modem
    type in address bar
    192.168.1.1/look.html
    Post results.

    Seems in NAT Virtual server option etc is not available in SW of unit supplied by BSNL. Addl menu items can be
    available in FW Update/ or some option will be removed.


    If the modem is on rent and you have a friendly BSNL JTO
    he may replace the modem, if the modem becomes useless!Try at your own risk
  5. George101

    George101 New Member

    this is wat i get
  6. essbebe

    essbebe LEARNER

    @George101. Thanks for the information.

    Your version appears latest.
    Board ID should be same ( see device status)
    mine: ( for ref beetel 110BX1)
    Board ID: 96338L-2M-8M
    Software Version: 3.12L.01.A2pB023k.d20k_rc2
    Bootloader (CFE) Version: 1.0.37-0.7

    better wait for more feedback.
    Code:
    If it works  don't repair it !
    Last edited: Oct 6, 2011
  7. komalselva

    komalselva New Member

    I have taken risk and it finally ended in failure.
    only the "DSL" is glowing now

    For what iam worrying is I have paid another 1500 to a Chinese


    Plz DON’T TRY THIS
  8. deepmohan

    deepmohan Its Time To Change !

    sorry mate to here this :(

    never ever try a firmware update until and unless you are sure about it.

    always the safest one to try is the one provided by the manufacturers.

    you could have seen this before proceeding.
    Last edited: Sep 3, 2009
  9. Indranil

    Indranil Member

    komalselva Can you browse the http://192.168.1.1
    I think I have the firmware 3.08.BSNL_02.01.02_tr64
    If you browse the gui page you can back to the old one.

    essbebe can you tell me please what is the GUI link of the beetel 110BX1
    is it http://192.168.1.1 or http://192.168.0.1
  10. essbebe

    essbebe LEARNER

    @komalselva
    Sorry to hear , your FW update was not successful.
    send me PM. the procedure you adopted.
    can try a command upgrade tool, to try to salvage the modem.
    if you can access the modem page, can you get some details ?
    @indranil
    [​IMG]
    Last edited: Sep 3, 2009
  11. rsk11584

    rsk11584 New Member

    Hello friends I am using UT 300R2U modem since 2006 and till date it runs as smooth and superb speed, so if its working fine do i still need to change firmware ??? ;-! pls advise
  12. essbebe

    essbebe LEARNER

    @rsk1184
    better wait for more feedback.
    see post no 2 4 & 6
    Code:
    If it works  don't repair it !
    
    Probably it is the old model.
    Post Device status screen shot as jpg picture.
    Para two:
    BSNL a modified version without
    Advanced Options like Virtual server/port triggering and other menu
    options.
    users need/want to use PF for torrents downloads.
  13. komalselva

    komalselva New Member

    iam not even able to access configuration page through 192.168.1.1.

    only the DSL and ethernet LEDs r glowing in my modem.while accuring ip automatically it not assigned to usual 192.168.1.xx it assigns to a ip similer to 56.234.32.34

    i also tried giving IP myself, but again it gives "Page cannot display" error

    Thanks,
    KomalSelva
  14. Indranil

    Indranil Member

    komalselva your Router IP is changed. It canot be open by 192.168.1.1.
    You can get the current router IP just follow this.

    In your lan device set accuring ip automatically
    it will give you the ip address like 56.234.32.34 you say

    Now go to RUN then type CMD
    in commend promt windows type IPCONFIG
    Look at the Default Gateway what it's say

    in your Internet Browser put this Gateway IP address. This is the current router IP address like it had before 192.168.1.1

    Remember to get the current router IP you have to set your Lan Card to Obtain an IP address automatically

    Your DSL light is glowing thats mean you router is OK
    even your firmware update was also OK.
  15. essbebe

    essbebe LEARNER

  16. komalselva

    komalselva New Member

    There is no gateway :confused:

    icrosoft(R) Windows DOS
    (C)Copyright Microsoft Corp 1990-2001.

    C:\DOCUME~1\KOMAL$~1>ipconfig/all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : IndicServer
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E E
    thernet Controller
    Physical Address. . . . . . . . . : 00-22-15-B7-A0-2A
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.12.67
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    C:\DOCUME~1\KOMAL$~1>

    Firmware not updated again

    Firmware updation Process May take 5 minutes time.
    Wait for the Modem to reboot
    ftp> open 192.168.1.1
    > ftp: connect :Unknown error number
    ftp> admin
    Invalid command.
    ftp> password
    Invalid command.
    ftp> hash
    Hash mark printing On ftp: (2048 bytes/hash mark) .
    ftp> put T28-0q-003.img
    Not connected.
    ftp> bye
    Updating Modem's ROM...

    Please wait while the Modem reboots...
    .
    .
    .


    The power Led is still off
    The DSL led is still on (without connecting ADSL line)
    The ethernet LED is Still blinking
    Last edited: Sep 3, 2009
  17. Indranil

    Indranil Member

    komalselva
    Pm me your email address or leave here
    I will send you the firmware 3.08.BSNL_02.01.02_tr64._fs_kernel

    try with it to back your router again.
    Try to upgrade the firmware from the Beetel220BX1 GUI web page

    Do you put the IP address in your Lancard
    like
    192.168.1.10
    255.255.255.0
    192.168.1.1

    Email has been sent
    give a replly
    Last edited: Sep 4, 2009
  18. komalselva

    komalselva New Member

    after i set up the above IP manually it works in another working modem, but its not working in faulty modem.

    i have attached screen shots

    Attached Files:

  19. Indranil

    Indranil Member

    Try with IP
    192.168.0.2
    255.255.255.0
    192.168.0.1

    The above IP is 0.1 not 1.1
    Some time the router have ip like this
    192.168.1.254
    or 192.168.1.100
    or 192.168.1.1
    or 192.168.0.1

    Not possible from here to tell you which one is you current router IP address
    or your router get faulty after the firmware update.
  20. komalselva

    komalselva New Member

    I tried but again no use.

    So I came to a conclusion that my modems firmware IC is became faulty. My friend is working in BSNL as JTO. tomorrow I am going to get a same model faulty modem and change the firmware with the help of a DVD Technition.(he is also friend who is having blower to remove and fix SMT ICs).
    iam going to do this just to know what happend to my modem while updating firmwere.

    Thanks for both Indranil and essbebe for ur helps


    I will update this thread if iam successful.
    Last edited: Sep 4, 2009

Share This Page