Error 651 with BSNL on Windows 7

Discussion in 'BSNL broadband' started by rsen, Nov 4, 2011.

  1. rsen

    rsen New Member

    Error 651/system hangs with BSNL on Windows 7 [Fixed]

    OS: windows 7
    modem - D-link GLB802C
    plan home 500 (night unlimited)
    connection mode bridged with dialer.

    I also have an Airtel connection which is working perfectly fine with the same modem (im posting from this connection).

    There is no noise on my BSNL telephone and the line is fine.

    I tried copying the vista rasdialer file from a previous forum post but it leads to a 813/797 modem not found error.

    I have also tried uninstalling and reinstalling the Intel Gigabit network connection entry from device manager and this didn't change anything either.

    Is this a temporary BSNL error or is something wrong on my end ?
    Last edited: Nov 4, 2011
  2. meetdilip

    meetdilip The Wizard

    I have seen member reporting that this issue vanish when you try PPPoE. Switch to PPPoE and check.
  3. rsen

    rsen New Member

    nope, switching connection mode did not fix the problem.

    I switched to pppoe in the modem quick config page; entered uname/pwd there then hit submit then commit/reboot; but there is no internet connection.

    Also my Airtel connection is working fine with bridged+dialer using the same modem and PC.
  4. player

    player New Member

    Open your modem page by entering 192.168.1.1

    Check whether your WAN settings are ok or not ... i.e. is it showing PPPoE up or not

    There are many guides floating around in this forum, do refer them
  5. rsen

    rsen New Member

    I changed back to Bridged for bsnl on my modem configuration page.

    Now whenever I try a bsnl connection the dialer just hangs, freezing up my computer.

    Strangely airtel connections on the same modem with bridged mode dial perfectly fine.

    Could it be something on bsnl's end ?
  6. meetdilip

    meetdilip The Wizard

    Are you able to use Airtel in PPPoE ?

    Are you using the same dialer for BSNL ? If not, delete the BSNL dialer, make a new one and check.

    May be something wrong at BSNL end. Someone from Kolkata can share if they are also facing the same issue. But it seems everyone got used to schedulers and are having a sound sleep now.
  7. rsen

    rsen New Member

    The Airtel connection is in bridged mode, I couldn't get it to work in PPPoE though.
    It works fine in bridge mode with a dialer.

    I'm using a different dialer for BSNL.
    I have tried using new dialers but the problem remains -

    Whenever I dial to bsnl, it get's stuck on connecting. After a few minutes a error 651 message pops up or my computer just hangs.

    maybe tomorrow there will be people from kolkata reporting similar problems.
  8. meetdilip

    meetdilip The Wizard

    May be you are using the incorrect settings to configure in PPPoE. From what I gather from feedback from other members, PPPoE can get rid of this issue. Try if you can configure it correctly, if it doesn't bear fruit, wait for feedback from Kolkata users.
  9. rsen

    rsen New Member

    Right now I switched back to bridged mode and every time I try a dialer I get a :

    "Connecting to WAN Miniport (PPPOE)..."
    dialog box, which just hangs after a few minutes and locks up my pc.
    This is what is usually happening with old and newly created dialers.
    No error message or anything, I have to hard reboot windows 7.

    Occasionally I also get a 651 error.

    Bridged mode seems a lot more convenient if you want to switch quickly between different dns servers; or switch between 2 connections (bsnl/airtel).

    It also seems easier to shchedule connection/disconnection with dialer mode.

    more info:

    the problem happens only with BSNL, airtel is still working fine in bridged mode using the same modem.

    With some dialer shortcuts windows hangs, with others I get error 651.
    Either way I cannot connect.

    1st I get a dialog saying it is trying to connect:
    [​IMG]

    After this it either goes to error 651 or the computer itself hangs.
    error 651 message:
    [​IMG]
    If it hangs it gets stuck on the connecting dialog for a few minutes, then suddenly my PC freezes up - in task manager explorer.exe starts using a ton of memory 1.6gb or more.

    After this If I go to the network adapter page I see various dialers stuck on "disconnecting".
    [​IMG]

    Here is my modem config page for BSNL:
    main page-
    [​IMG]
    quick config page-
    [​IMG]

    Also here are the DSL parameters from the bsnl line:

    Local Tx Power: 10.7 dB
    Remote Tx Power: 15.6 dB
    Local Line Atten.: 11.0 dB
    Remote Line Atten.: 5.5 dB
    Local SNR Margin: 22.5 dB
    Remote SNR Margin: 18.0 dB
    Self Test: Passed
    DSL Standard: G.dmt
    Profile: MII
    Tx Line Rate: 640 Kbps
    Rx Line Rate: 6144 Kbps

    Called up BSNL in the morning, now everything is fine...

    Bizarre problem, never thought my PC freezing up or error 651 would be something wrong on their end.
    Last edited: Nov 4, 2011
  10. pkm.sbp

    pkm.sbp New Member

    Yes, it's possible.There may be some problem from the Knob(Bangalore).

Share This Page