Configuring Siemens SL2-141 Wireless for Port Forwarding

Discussion in 'BSNL broadband' started by abhilashkmanapatt, Apr 14, 2008.

  1. abhilashkmanapatt

    abhilashkmanapatt New Member

    Hi friends, I had been requesting for help and searching all over the internet on how to configure the BSNL Wireless Router (Siemens SL2-141) to enable Port Forwarding. The uTorrent downloads were not active and I had the infamous RED exclamation mark that shows an Error in incoming connections.

    The other routers supplied by BSNL is easy to configure, all you need to do is login as admin(with password admin) to the router menu(192.168.1.1 IP address mostly), and add a Virtual Server(which is given under Advanced Options). From there we can name our service as "uTorrent" (any name) and add our computer's IP address(make it static, just give an IP address that comes under your routers internally assigned IP) plus the port to be forwarded(which u can get from uTorrent).

    But, it was difficult to configure this particular router as the Router Configuration menu did not give an Advanced option even if I log in as an admin user. I tried to login using a fictious superuser, but it did not work.

    But finally, I solved it and now, I am able to get the incoming connections in my uTorrent and the upload also works fine. I have the green check mark to my relief :)

    How did I do it?

    I used the TELNET option and configured the Router. It is a very simple procedure and far more easier. IT WORKS FOR ALL THE ROUTERS, NO MATTER WHAT EVER THE MAKE IS ;)

    How to do it?

    1. Get HyperTerminal, you can find it from Start>Accessories>Communication (for Windows users)
    2. A "New Connection" window will open uip asking you to enter a name and choose an icon for the connection. You can give any name here and choose any icon. If the window doesn't pop up, then click on File>New Conncetion.
    3. In the next window choose the "Connect Using" option as "TCP/IP(Winsock)" [Very Important] and then choose the Host address as 192.168.1.1(the router IP address) and the Port as 23.
    4.It will take you to the Login menu, enter the login and password as "admin"(when you type the password, it won't show any asterisk or any other character, keep on typing)
    5.Thats it, we are now in the Advanced Options of the Router setup.
    6. Enter the menu option 6 that corresponds to NAT to enter the NAT configuration
    7.It gives you 3 options and from that choose Virtual Server(ie, 1) and then choose Add
    8. You can give any service name here, i gave the name as uTorrent and for Protocol choose the option 0(Zero - for tcp and udp)
    9. The External Start port, end port, Internal Start port, end port > Enter it exactly same as the port given in uTorrent.(yes, all four) [I am not very sure about the exact value to give, but it worked for me when i entered the same port in uTorrent for all four port settings]
    10. Give the internal IP address as your computer's IP address [I set my computer's IP address as 192.168.1.2]
    11. Now, the router will save the information and you can exit (by hitting 4 and then 3) and then reboot the router by pressing 13. It will show some process kills and then after 30secs-1min, it will reboot. Wait for 1 minute and then login to the router again(By using HyperTerminal, follow steps 1, 2,3,4)
    12. Now, check in the uTorrent, if its accepting the connections and is forwarding the Port. It should work for most of you out there
    13. If it does not, then, go to NAT setup through the HyperTerminal again, and go to DMZ and choose Configure and give you computer's IP address. The network traffic will be open. Make sure that you have a good antivirus and a firewall installed in your computer. You can give the Firewall exception for uTorrent though. I suggest downloading and installing Avast! Antivirus for that.

    Attached Files:

  2. superprash2003

    superprash2003 New Member

    good job dude.. nice tutorial... hope it helps a lot of people..you might want to edit the title of the thread and add a HOWTO: in the beginning
  3. player

    player New Member

    whoa!...........thats very good, great job abhilashkmanapatt .............man you should go in MIT or something..........

    @Admin can you please make this sticky post..

    looking forward..
  4. whitestar_999

    whitestar_999 Platinum Member

    its a known fact that you can use telnet to access those functions of modem which otherwise are not visible in web mode.i have already tried it with some other models but for siemens c2110 this doesn't work for some reason because when you login you don't get any menu options like press 1,2...etc but only a blank screen where typing ? gives you commands only but when you type any command it gives"command unrecognized"error.i suppose SL2_141 is different.still your guide will be useful to those users who use SL2_141 because as far as i know all other modem's web configuration has NAT,virtual server etc except newer ut300r2u(can you check it superprash2003 with your modem using telnet if virtual server option can be accessed?).

    PS---is there any specific reason to use hyper terminal because i always use telnet from command prompt?
  5. abhilashkmanapatt

    abhilashkmanapatt New Member

    @whitestar

    i haven't got the chance to use the c2110 modem and so, i donno how to configure that. well, if u wanna know, i will do some research and see if any of my frns have that modem and will surely try it out in their computer.

    And, HyperTermnial, only because you can save the connection settings and stuff like that.

    Command prompt is very good, and most times i use that. No specific reason why i referred to HyperTerminal in the post.

    For those who are interested in knowing the command prompt telnet,

    1. Get the command prompt (Start>Run>cmd)
    2. type in telnet
    3.it takes you to the Microsoft Telnet prompt
    4. type o (for open) followed by the IP address of the router and viola you are in the router, type in the username and password, the configuration menus are same as that had been mentioned in the first post of this thread.

    * type in help, to view the most common commands in telnet (from the telnet prompt)

    Thanx for everyone's response :) and thanx whitestar for letting me know abt the c2110, will surely see if i can try out and find a way through telnet.
  6. whitestar_999

    whitestar_999 Platinum Member

    never mind.i figured it out but i must admit using telnet in c2110 is very difficult & time consuming in comparison to any other modem i have seen.only those who are very good at using telnet will be able to understand & it is far more easier to use the way which i described above(clicking on help link in firmware update & from the help page you can access all advanced functions).
  7. adeeshc

    adeeshc New Member

    Thanx for the info. Really workd out gr8. Good work!
  8. just4kix

    just4kix Guardian Angel Staff Member

    Good job.
  9. killerz

    killerz New Member

    thanks very much abhilashkmanapatt, it works like a charm.!
  10. dik9211

    dik9211 New Member

    i m using siemans SL2_141. how can i config port forwarding 4 wifi. becouse it dont have any ip, it connect automaticly.
    so, plz give me solution:eek:
  11. superprash2003

    superprash2003 New Member

    go to the command prompt of your wifi laptop or pc.. and type ipconfig .. you should get an ip like 192.168.1.x use that ip and port forward as mentioned in the first post..
  12. player

    player New Member

  13. dik9211

    dik9211 New Member

    thanks budy
    its working:):rolleyes::cool:
  14. dik9211

    dik9211 New Member

    i m using Siemens SL2-141 with port forwarding. when i connect it with LAN, i face a problem, it give full connectivity 2 utorrent and it working fine.

    But it don't give connectivity 2 any other software.mean browser not open any site. gtalk fail 2 connect......etc

    i working fine with wi-fi with port forwarding. but problem is in only LAN


    so help me out. how can i resolve it
  15. superprash2003

    superprash2003 New Member

    open your browser and type 64.233.187.99 .. does the google page open? if so, then you have a DNS problem.. try opening Google
  16. dik9211

    dik9211 New Member

    can u tell how u become gold member and what is the benifit of it
  17. dik9211

    dik9211 New Member

    no dear google is not open:confused::(
  18. whitestar_999

    whitestar_999 Platinum Member

    member status is determined by no.of posts.as for benefit there is none if you mean such members have some special rights.as for your problem post here how you set the rules in port forwarding options & don't use virtual server.post some screenshots of rules page if you have to.
  19. superprash2003

    superprash2003 New Member

    also type ping google.com in your command prompt and post output..
  20. dranirbanpoddar

    dranirbanpoddar New Member

    VERY INFORMATIVE THREAD......I THOUGHT OF CONTRIBUTING MY 2 CENTS TOO.GUYS IN CASE OF THE SL2_141 MODEM THE ADVANCED OPTIONS & VARIOUS OTHER OPTIONS ARE NOT AVAILABLE ON OPENING http://192.168.1.1
    instead of this open http://192.168.1.1/main.html ....when this page opens you can access all the features & advanced options in the web interface itself & you will not need hyperterminal....hope its of some help........:eek::eek::eek:

Share This Page